您的位置:首页 > 其它

Corn Fields - POJ 3254 状压dp

2014-07-07 18:45 295 查看
Corn Fields

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 6800Accepted: 3614
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:

1 2 3
  4


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:牛只能在肥沃的土地上吃草,并且两头牛不能上下左右挨着,问你可以有多少种吃草方案。

思路:状压dp。先把一行内不挨着的情况找出来,一共是980多种,然后第一行先判断这些情况存在的。然后后面的行,每种情况先判断这种情况在该行能不能满足,再判断与上一行是否有挨着的。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int row[20],state[1010];
int dp[20][1010],mod=100000000,ans;
int main()
{ int m,n,i,j,k,num=0;
  scanf("%d%d",&m,&n);
  k=1<<n;
  for(i=0;i<k;i++)
   if((i&(i<<1))==0)
    state[num++]=i;
  for(i=0;i<m;i++)
   for(j=n-1;j>=0;j--)
   { scanf("%d",&k);
     row[i]+=k<<j;
   }
  for(i=0;i<num;i++)
   if((row[0]&state[i])==state[i])
    dp[0][i]=1;
  for(i=1;i<m;i++)
   for(j=0;j<num;j++)
   { if((row[i]&state[j])!=state[j])
      continue;
     for(k=0;k<num;k++)
      if(dp[i-1][k] && ((state[k] & state[j])==0))
       dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
   }
  ans=0;
  for(i=0;i<num;i++)
   ans=(ans+dp[m-1][i])%mod;
  printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: