您的位置:首页 > 其它

POJ-1068--Parencodings

2014-07-07 13:16 357 查看
Parencodings

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 19287Accepted: 11630
Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题目大意:

当前右括号之前有多少个匹配的

思路:

'('=-1,')'=1

例如(((()()())))

为-1,-1,-1,-1,1,-1,1,-1,1,1,1,1

第4个右括号前的匹配数为,与前一个相加,直到和为0,则:1+1+-1+1+-1+1+-1+-1=0(从第10个位置往前加到第3个位置,加了8次,所以匹配数为8/2=4.


#include<iostream>
using namespace std;
int n,o,m[500],a[25]={0};
void KuoHao()//转化为数组,左括号为-1,右括号为1
{
    int i,j,t;
    for(i=1;i<=n;i++)
    {
        t=a[i]-a[i-1];
        for(j=0;j<t;j++)
        {
            m[o++]=-1;
        }
        m[o++]=1;
    }
}
int main()
{
    int i,j,k,sum,p;
    cin>>k;
    while(k--)
    {
        cin>>n;
        o=0;
        for(i=1;i<=n;i++) cin>>a[i];
        KuoHao();
        for(i=1;i<o;i++)//将右括号前的数字累加,直到代数和为0
        {
            if(m[i]==1)
            {
                j=i;
                sum=p=1;
                while(sum)
                {
                    sum+=m[--j];
                    p++;
                }
                cout<<p/2;
                if(i!=o-1) cout<<" ";
            }

        }
        cout<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: