您的位置:首页 > 其它

ZJU-PAT 1065. A+B and C (64bit) (20)

2014-07-06 12:00 465 查看
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

分析:

1.考虑相加溢出的情况

(1)  a > 0 && b>0 && a+b <0  , 因 a+b > c,故true

(2)  a < 0 && b<0 && a+b >0 , 因 a+b < c,故false

2. PAT上不支持 __int64数据,採用[b]long long型数据[/b]



#pragma warning (disable:4786)
#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;

int main()
{
int T;
cin>>T;
for(int i=1;i<=T;i++)
{
long long int  a,b,c;
cin>>a>>b>>c;

cout<<"Case #"<<i+1<<": ";

bool flag;
long long ans =a+b;
if(a>0 && b>0 && ans<=0)
flag=true;
else if(a<0 && b <0 && ans >= 0)
flag=false;
else
flag = (ans > c);
if(flag)
cout<<"true"<<endl;
else
cout<<"false"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: