您的位置:首页 > 其它

HDU 1712 ACboy needs your help 分组背包

2014-07-05 22:17 495 查看

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3813 Accepted Submission(s): 1981


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the
profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0


Sample Output
3
4
6


/*
HDU 1712 背包问题 dp
分组背包 
使用一维数组的伪代码如下:
for 所有的组k
    for v=V..0
        for 所有的i属于组k
            f[v]=max{f[v],f[v-c[i]]+w[i]}
*/

#include<iostream>
#include<cstring>
using namespace std;
int main(){
    
    int c,n,m,i,j,k,v[101][101],dp[101];
    
    while(scanf("%d%d",&n,&m))//n课程数 m拥有天数 
    {
        if(n==0&&m==0) break;
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
            scanf("%d",&v[i][j]);//第i节课 用j天 可以得到的profit 
        memset(dp,0,sizeof(dp));    
        
        for(i=1;i<=n;i++)         //分组
            for(j=m;j>=1;j--)    //背包容量 
                for(k=1;k<=j;k++)//不同时间的课程
                    if(j>=k&&dp[j]<dp[j-k]+v[i][k])
                        dp[j]=dp[j-k]+v[i][k]; 
        printf("%d\n",dp[m]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: