您的位置:首页 > 其它

HDU 1250: Hat's Fibonacci

2014-07-05 20:53 253 查看


Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6925 Accepted Submission(s): 2279



Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.



Input

Each line will contain an integers. Process to end of file.



Output

For each case, output the result in a line.



Sample Input

100




Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


import java.math.BigInteger;     
import java.util.Scanner;     
  
public class Main {     
    
    public static void main(String[] args) {     
        Scanner cin = new Scanner((System.in));     
        int  n;  
        BigInteger[] f = new BigInteger[10000];  
        f[1] = BigInteger.ONE;  
        f[2] = BigInteger.ONE;  
        f[3] = BigInteger.ONE;  
        f[4] = BigInteger.ONE;  
        for(int i=5; i<f.length;i++)   
            f[i] = f[i-1].add(f[i-2].add(f[i-3].add(f[i-4])));  
        while(cin.hasNext()){  
            n = cin.nextInt();  
            System.out.println(f
);  
        }  
    }     
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: