您的位置:首页 > 其它

POJ-1163-The Triangle

2014-07-05 16:16 453 查看
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


Sample Output
30


动态规划:自下(从第n行开始)而上的查找!第n+1行所有的值均为0,所以for循环的第一步是将自身保存起来!

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    int a[131][141];
    memset(a,0,sizeof(a));
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
        for(int j=1; j<=i; j++)
            scanf("%d",&a[i][j]);
    for(int i=n; i>=1; i--)//从左下角开始!
        for(int j=1; j<=i; j++)
        {
            a[i][j]+=max(a[i+1][j],a[i+1][j+1]);
            //printf("a[%d][%d]的值为:%d\n",i,j,a[i][j]);
        }
    printf("%d\n",a[1][1]);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: