您的位置:首页 > Web前端

POJ 2761 Feed the dogs

2014-07-05 15:02 736 查看
Feed the dogs

Time Limit: 6000MSMemory Limit: 65536K
Total Submissions: 15298Accepted: 4715
Description

Wind loves pretty dogs very much, and she has n pet dogs. So Jiajia has to feed the dogs every day for Wind. Jiajia loves Wind, but not the dogs, so Jiajia use a special way to feed the dogs. At lunchtime, the dogs will stand on one line, numbered from 1 to
n, the leftmost one is 1, the second one is 2, and so on. In each feeding, Jiajia choose an inteval[i,j], select the k-th pretty dog to feed. Of course Jiajia has his own way of deciding the pretty value of each dog. It should be noted that Jiajia do not want
to feed any position too much, because it may cause some death of dogs. If so, Wind will be angry and the aftereffect will be serious. Hence any feeding inteval will not contain another completely, though the intervals may intersect with each other.

Your task is to help Jiajia calculate which dog ate the food after each feeding.

Input

The first line contains n and m, indicates the number of dogs and the number of feedings.

The second line contains n integers, describe the pretty value of each dog from left to right. You should notice that the dog with lower pretty value is prettier.

Each of following m lines contain three integer i,j,k, it means that Jiajia feed the k-th pretty dog in this feeding.

You can assume that n<100001 and m<50001.

Output

Output file has m lines. The i-th line should contain the pretty value of the dog who got the food in the i-th feeding.
Sample Input
7 2
1 5 2 6 3 7 4
1 5 3
2 7 1

Sample Output
3
2

Source

POJ Monthly--2006.02.26,zgl & twb

解题思路:划分树模板题

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Maxn=100010;
int tree[20][Maxn];
int sorted[Maxn];
int toleft[20][Maxn];
void build(int l,int r,int dep)
{
	if(l==r)
		return ;
	int mid=(l+r)>>1;
	int same=mid-l+1;
	for(int i=l;i<=r;i++)
		if(tree[dep][i]<sorted[mid])
			same--;
	int lpos=l;
	int rpos=mid+1;
	for(int i=l;i<=r;i++)
	{
		if(tree[dep][i]<sorted[mid])
			tree[dep+1][lpos++]=tree[dep][i];
		else if(tree[dep][i]==sorted[mid]&&same>0)
			tree[dep+1][lpos++]=tree[dep][i],same--;
		else
			tree[dep+1][rpos++]=tree[dep][i];
		toleft[dep][i]=toleft[dep][l-1]+lpos-l;
	}
	build(l,mid,dep+1);
	build(mid+1,r,dep+1);
}
int query(int L,int R,int l,int r,int dep,int k)
{
	if(l==r)
		return tree[dep][l];
	int mid=(L+R)>>1;
	int cnt=toleft[dep][r]-toleft[dep][l-1];
	if(cnt>=k)
	{
		int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
		int newr=newl+cnt-1;
		return query(L,mid,newl,newr,dep+1,k);
	}
	else
	{
		int newr=r+toleft[dep][R]-toleft[dep][r];
		int newl=newr-(r-l-cnt);
		return query(mid+1,R,newl,newr,dep+1,k-cnt);
	}
}
int main()
{
	int n,m;
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	while(~scanf("%d%d",&n,&m))
	{
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++)
			scanf("%d",&tree[0][i]),sorted[i]=tree[0][i];
		sort(sorted+1,sorted+1+n);
		build(1,n,0);
		while(m--)
		{
			int l,r,k;
			scanf("%d%d%d",&l,&r,&k);
			printf("%d\n",query(1,n,l,r,0,k));
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: