您的位置:首页 > 其它

Play the Dice - HDU 4586 dp

2014-07-05 12:22 323 查看


Play the Dice

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 871 Accepted Submission(s): 305

Special Judge


Problem Description

There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai
yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling
chance. Now you need to calculate the expectations of money that we get after playing the game once.



Input

Input consists of multiple cases. Each case includes two lines.

The first line is an integer n (2<=n<=200), following with n integers ai(0<=ai<200)

The second line is an integer m (0<=m<=n), following with m integers bi(1<=bi<=n), which are the numbers of the special sides to get another more chance.



Output

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.



Sample Input

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3




Sample Output

3.50
0.00


题意:一个骰子有n个面,可以得到这个面上数字所对应的钱数,然后投到m个面上时可以再掷一次,问你每次掷的和的期望是多少。

思路:第一次得到的前是sum/n,然后有m/n的概率再掷一次,那么就应该是sum/n+m/n*sum/n,再往下推,是一个等比数列。然后就能得到ans=sum/(n-m)。另外优先考虑一下几种特殊情况。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num[210];
int main()
{ int n,m,i,j,k,sum;
  double ans;
  while(~scanf("%d",&n) && n>0)
  { sum=0;
    for(i=1;i<=n;i++)
    { scanf("%d",&num[i]);
      sum+=num[i];
    }
    scanf("%d",&m);
    for(i=1;i<=m;i++)
     scanf("%d",&k);
    if(sum==0)
    { printf("0.00\n");
    }
    else if(n==m)
    printf("inf\n");
    else
    { ans=sum*1.0/(n-m);
      printf("%.2f\n",ans);
    }
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: