您的位置:首页 > 其它

hdu1301&poj1251 Jungle Roads(最小生成树之prim果题)

2014-07-02 21:02 429 查看
转载请注明出处:http://blog.csdn.net/u012860063

题目链接:

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1301

POJ: http://poj.org/problem?id=1251

Problem Description



The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The
Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads,
even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through
I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet,
capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to
villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road.
Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more
than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute
time limit.



Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0




Sample Output

216
30




Source

Mid-Central USA 2002



Recommend

Eddy

一道prim算法的果题!





题目很长,这里就不贴题目了。



题意: 给你每个村庄之间的维护道路的费用,求最小的费用。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define INF 0xfffffff
#define N 147
int map

;
int dis
,vis
;
//创建map二维数组储存图表,dis数组记录每2个点间最小权值.
//vis
数组标记某点是否已访问 
int min(int a, int b)
{
	return a<b?a:b;
}

int prim(int n, int sta)
{
	int i, j, k, MIN, sum = 0;
	for(i = 1; i <= n; i++)//第一次给dis数组赋值 
	{
		dis[i]=map[sta][i];
		vis[i] = 0;
	}
	vis[sta] = 1;//从某点开始,分别标记和记录该点
	for(i = 1; i < n; i++)//再运行n-1次  
	{
		MIN = INF; k = 0;
		for(j = 1; j <= n; j++)
		{
			if(vis[j]==0 && dis[j]<MIN)//找出最小权值并记录位置
			{
				k = j;
				MIN = dis[j];
			}
		}
		if(k != 0)
		{
			vis[k] = 1; //标记该点
			sum+=dis[k];//最小权值累加 
			for(j = 1; j <= n; j++)//更新权值
			{
				dis[j] = min(map[k][j],dis[j]);
			}
		}
	}
	return sum;
}

int main()
{
	int n, i, j, k, m,t;
	char ch,tt;
	int sum;
	while(cin >> n && n)
	{
		for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                map[i][j]=INF;
			for(i = 1; i < n; i++)
			{
				cin>>ch>>m;
				for(j = 1; j <= m; j++)
				{
					cin>>tt>>t;
					//防止有重边出现
					map[ch-'A'+1][tt-'A'+1]=min(map[ch-'A'+1][tt-'A'+1],t);
					map[tt-'A'+1][ch-'A'+1]=map[ch-'A'+1][tt-'A'+1];
				}
			}
			sum = prim(n,1);
			cout<<sum<<endl;
	}
	return 0;
}




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: