您的位置:首页 > 其它

hdu 1398 Square Coins (母函数)

2014-07-02 10:57 405 查看

Square Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7883 Accepted Submission(s): 5332


[align=left]Problem Description[/align]
People
in Silverland use square coins. Not only they have square shapes but
also their values are square numbers. Coins with values of all square
numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins,
9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

[align=left]Input[/align]
The
input consists of lines each containing an integer meaning an amount to
be paid, followed by a line containing a zero. You may assume that all
the amounts are positive and less than 300.

[align=left]Output[/align]
For
each of the given amount, one line containing a single integer
representing the number of combinations of coins should be output. No
other characters should appear in the output.

[align=left]Sample Input[/align]

2
10

30
0

[align=left]Sample Output[/align]

1
4
27

[align=left]Source[/align]
Asia 1999, Kyoto (Japan)

[align=left]Recommend[/align]
Ignatius.L | We have carefully selected several similar problems for you: 2152 2082 2079 2069 2110

母函数入门题

//0MS    200K    615 B    G++
#include<stdio.h>
#define N 305
int c1
,c2
;
int _n[18]={1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289};
int fun(int n)
{
int i,j,k;
for(i=0;i<=n;i++){
c1[i]=1;
c2[i]=0;
}
for(i=1;i<17;i++){
for(j=0;j<=n;j++)
for(k=0;k+j<=n;k+=_n[i])
c2[j+k]+=c1[j];
for(j=0;j<=n;j++){
c1[j]=c2[j];
c2[j]=0;
}
}
return c1
;
}
int main(void)
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==0) break;
printf("%d\n",fun(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: