您的位置:首页 > 产品设计 > UI/UE

【HDU】1711 Number Sequence KMP

2014-06-27 17:01 453 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10306 Accepted Submission(s): 4681



Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2],
...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.



Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains
N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].



Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.



Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1




Sample Output
6
-1




Source
HDU 2007-Spring Programming Contest

传送门:【HDU】1711 Number Sequence

KMP模板题。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

const int maxN = 1000005 ;
const int maxM = 10005 ;

int fail[maxM] ;
int s[maxN] , p[maxM] ;

void Get_Fail ( int len ) {
	fail[1] = 0 ;
	for ( int i = 2 , j = 0 ; i <= len ; ++ i ) {
		while ( j && p[i] != p[j + 1] ) j = fail[j] ;
		if ( p[i] == p[j + 1] ) ++ j ;
		fail[i] = j ;
	}
}

int KMP ( int lens , int lenp ) {
	for ( int i = 1 , j = 0 ; i <= lens ; ++ i ) {
		while ( j && s[i] != p[j + 1] ) j = fail[j] ;
		if ( s[i] == p[j + 1] ) {
			++ j ;
			if ( j == lenp ) return i - j + 1 ;
		}
		else j = fail[j] ;
	}
	return -1 ;
}

int read () {
	int x = 0 , flag = 0 ;
	char ch = ' ' ;
	while ( ch != '-' && ( ch < '0' || ch > '9' ) ) ch = getchar () ;
	if ( ch == '-' ) {
		flag = 1 ;
		ch = getchar () ;
	}
	while ( ch >= '0' && ch <= '9' ) x = x * 10 + ch - '0' , ch = getchar () ;
	return flag ? -x : x ;
}

void work () {
	int n , m ;
	scanf ( "%d%d" , &n , &m ) ;
	for ( int i = 1 ; i <= n ; ++ i ) s[i] = read () ;
	for ( int i = 1 ; i <= m ; ++ i ) p[i] = read () ;
	Get_Fail ( m ) ;
	printf ( "%d\n" , KMP ( n , m ) ) ;
}

int main () {
	int T ;
	scanf ( "%d" , &T ) ;
	while ( T -- ) work () ;
	return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: