您的位置:首页 > 其它

POJ 3580 SuperMemo

2014-06-27 09:25 260 查看
裸Splay区间操作: 内存池+区间加减+区间翻转+插入+删除+维护最值

SuperMemo

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 8552Accepted: 2801
Case Time Limit: 2000MS
Description

Your friend, Jackson is invited to a TV show called SuperMemo in which the participant is told to play a memorizing game. At first, the host tells the participant a sequence of numbers, {A1,A2, ... An}.
Then the host performs a series of operations and queries on the sequence which consists:

ADD x y D: Add D to each number in sub-sequence {Ax ... Ay}. For example, performing "ADD 2 4 1" on {1, 2, 3, 4, 5} results in {1, 3, 4, 5, 5}
REVERSE x y: reverse the sub-sequence {Ax ... Ay}. For example, performing "REVERSE 2 4" on {1, 2, 3, 4, 5} results in {1, 4, 3, 2, 5}
REVOLVE x y T: rotate sub-sequence {Ax ... Ay} T times. For example, performing "REVOLVE 2 4 2" on {1, 2, 3, 4, 5} results in {1, 3, 4, 2, 5}
INSERT x P: insert P after Ax. For example, performing "INSERT 2 4" on {1, 2, 3, 4, 5} results in {1, 2, 4, 3, 4, 5}
DELETE x: delete Ax. For example, performing "DELETE 2" on {1, 2, 3, 4, 5} results in {1, 3, 4, 5}
MIN x y: query the participant what is the minimum number in sub-sequence {Ax ... Ay}. For example, the correct answer to "MIN 2 4" on {1, 2, 3, 4, 5} is 2

To make the show more interesting, the participant is granted a chance to turn to someone else that means when Jackson feels difficult in answering a query he may call you for help. You task is to watch the TV show and write a program giving the correct
answer to each query in order to assist Jackson whenever he calls.

Input

The first line contains n (n ≤ 100000).

The following n lines describe the sequence.

Then follows M (M ≤ 100000), the numbers of operations and queries.

The following M lines describe the operations and queries.

Output

For each "MIN" query, output the correct answer.

Sample Input

5
1
2
3
4
5
2
ADD 2 4 1
MIN 4 5

Sample Output

5

Source

POJ Founder Monthly Contest – 2008.04.13, Yao Jinyu
[Submit] [Go Back] [Status]
[Discuss]

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=220000;
const int INF=0x3f3f3f3f;
#define Key_Value ch[ch[root][1]][0]

int ch[maxn][2],rev[maxn],add[maxn],sz[maxn],pre[maxn],key[maxn],minn[maxn];
int root,tot1;
int s[maxn],tot2;

int n,q,a[maxn];

void NewNode(int& x,int father,int k)
{
if(tot2) x=s[tot2--];
else x=++tot1;

ch[x][0]=ch[x][1]=rev[x]=add[x]=0;
sz[x]=1; pre[x]=father; key[x]=minn[x]=k;
}

void Erase(int r)
{
if(r)
{
s[++tot2]=r;
Erase(ch[r][0]);
Erase(ch[r][1]);
}
}

void Upd_Rev(int x)
{
if(!x) return ;
swap(ch[x][0],ch[x][1]);
rev[x]^=1;
}

void Upd_Add(int x,int d)
{
if(!x) return ;
key[x]+=d; minn[x]+=d;
add[x]+=d;
}

void Push_Up(int x)
{
sz[x]=sz[ch[x][1]]+sz[ch[x][0]]+1;
minn[x]=key[x];
if(ch[x][0]) minn[x]=min(minn[x],minn[ch[x][0]]);
if(ch[x][1]) minn[x]=min(minn[x],minn[ch[x][1]]);
}

void Push_Down(int x)
{
if(rev[x])
{
Upd_Rev(ch[x][0]); Upd_Rev(ch[x][1]);
rev[x]=0;
}
if(add[x])
{
Upd_Add(ch[x][0],add[x]); Upd_Add(ch[x][1],add[x]);
add[x]=0;
}
}

void Build(int& x,int l,int r,int fa)
{
if(l>r) return ;
int mid=(l+r)/2;
NewNode(x,fa,a[mid]);
Build(ch[x][0],l,mid-1,x);
Build(ch[x][1],mid+1,r,x);
Push_Up(x);
}

void Init()
{
root=tot1=tot2=0;
ch[root][0]=ch[root][1]=pre[root]=sz[root]=0;
minn[root]=key[root]=INF;
NewNode(root,0,INF);
NewNode(ch[root][1],root,INF);
Build(Key_Value,1,n,ch[root][1]);
Push_Up(ch[root][1]);
Push_Up(root);
}

void Rotate(int x,int kind)
{
int y=pre[x];
Push_Down(y);
Push_Down(x);
ch[y][!kind]=ch[x][kind];
pre[ch[x][kind]]=y;
if(pre[y]) ch[pre[y]][ch[pre[y]][1]==y]=x;
pre[x]=pre[y];
pre[y]=x;
ch[x][kind]=y;
Push_Up(y);
}

void Splay(int r,int goal)
{
Push_Down(r);
while(pre[r]!=goal)
{
if(pre[pre[r]]==goal)
{
Push_Down(pre[r]);
Push_Down(r);
Rotate(r,ch[pre[r]][0]==r);
}
else
{
Push_Down(pre[pre[r]]);
Push_Down(pre[r]);
Push_Down(r);
int y=pre[r];
int kind=(ch[pre[y]][0]==y);
if(ch[y][kind]==r) Rotate(r,!kind);
else Rotate(y,kind);
Rotate(r,kind);
}
}
Push_Up(r);
if(goal==0) root=r;
}

int Get_Kth(int r,int k)
{
Push_Down(r);
int t=sz[ch[r][0]]+1;
if(k==t) return r;
if(t<k) return Get_Kth(ch[r][1],k-t);
else return Get_Kth(ch[r][0],k);
}

int Get_Min(int r)
{
Push_Down(r);
while(ch[r][0])
{
r=ch[r][0];
Push_Down(r);
}
return r;
}

int Get_Max(int r)
{
Push_Down(r);
while(ch[r][1])
{
r=ch[r][1];
Push_Down(r);
}
return r;
}

///.......do..it........

void ADD(int l,int r,int d)
{
Splay(Get_Kth(root,l),0);
Splay(Get_Kth(root,r+2),root);
Upd_Add(Key_Value,d);
Push_Up(ch[root][1]);
Push_Up(root);
}

void REVERSE(int l,int r)
{
Splay(Get_Kth(root,l),0);
Splay(Get_Kth(root,r+2),root);
Upd_Rev(Key_Value);
Push_Up(ch[root][1]);
Push_Up(root);
}

void DELETE(int p)
{
Splay(Get_Kth(root,p),0);
Splay(Get_Kth(root,p+2),root);
Erase(Key_Value);
pre[Key_Value]=0;
Key_Value=0;
Push_Up(ch[root][1]);
Push_Up(root);
}

void INSERT(int p,int v)
{
Splay(Get_Kth(root,p+1),0);
Splay(Get_Kth(root,p+2),root);
NewNode(Key_Value,ch[root][1],v);
Push_Up(ch[root][1]);
Push_Up(root);
}

int MIN(int l,int r)
{
Splay(Get_Kth(root,l),0);
Splay(Get_Kth(root,r+2),root);
return minn[Key_Value];
}

void REVOLVE(int l,int r,int t)
{
int len=r-l+1;
t=(t%len+len)%len;
if(t==0) return ;
int c=r-t+1;
///[l..c-1] and [c..r]
Splay(Get_Kth(root,c),0);
Splay(Get_Kth(root,r+2),root);
int temp=Key_Value;
Key_Value=0;
Push_Up(ch[root][1]);
Push_Up(root);

Splay(Get_Kth(root,l),0);
Splay(Get_Kth(root,l+1),root);
Key_Value=temp;
pre[Key_Value]=ch[root][1];
Push_Up(ch[root][1]);
Push_Up(root);
}
/****************Debug*********************/

void showit(int x)
{
if(x)
{
Push_Down(x);
showit(ch[x][0]);
printf("结点: %2d key: %2d 左儿子: %2d 右儿子: %2d 父结点: %2d sz: %2d min: %2d \n",
x,key[x],ch[x][0],ch[x][1],pre[x],sz[x],minn[x]);
showit(ch[x][1]);
}
}

void Debug()
{
cout<<"---------------------------\n";
cout<<"root: "<<root<<endl;
showit(root);
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++) scanf("%d",a+i);
Init();
// Debug();
scanf("%d",&q);
char op[100]; int x,y,z;
while(q--)
{
scanf("%s",op);
if(strcmp(op,"ADD")==0)
{
scanf("%d%d%d",&x,&y,&z);
ADD(x,y,z);
}
else if(strcmp(op,"REVERSE")==0)
{
scanf("%d%d",&x,&y);
REVERSE(x,y);
}
else if(strcmp(op,"REVOLVE")==0)
{
scanf("%d%d%d",&x,&y,&z);
REVOLVE(x,y,z);
}
else if(strcmp(op,"INSERT")==0)
{
scanf("%d%d",&x,&y);
INSERT(x,y);
}
else if(strcmp(op,"DELETE")==0)
{
scanf("%d",&x);
DELETE(x);
}
else if(strcmp(op,"MIN")==0)
{
scanf("%d%d",&x,&y);
printf("%d\n",MIN(x,y));
}
// Debug();
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: