您的位置:首页 > 其它

hdu 1071 the area 用积分求面积

2014-06-26 15:06 316 查看
题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1071

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7011    Accepted Submission(s): 4934


[align=left]Problem Description[/align]
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



 
 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 
 

[align=left]Output[/align]
For each test case, you should output the area of the land, the result should be rounded to 2 decimal p
4000
laces.
 
 

[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

 
 

[align=left]Sample Output[/align]

33.33
40.69

Hint

For float may be not accurate enough, please use double instead of float.

 
分析:  计算抛物线和直线方程, 代入求积分即可。
代码如下:

#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <vector>
using namespace std;
typedef long long ll;
double x1,y11,k,b,a;
// 积分
double f(double x)    // 不定积分值
{
return a*(x-x1)*(x-x1)*(x-x1)/3.0 - k/2*x*x+(y11-b)*x;
}

int main() {
double x2,y2,x3,y3;
int t;
cin>>t;
while(t--)
{
cin>>x1>>y11>>x2>>y2>>x3>>y3;
a=(y3-y11)/((x3-x1)*(x3-x1));
k=(y3-y2)/(x3-x2);
b=y3-k*x3;
printf("%.2f\n",f(x3)-f(x2));  // 定积分代入上下限
}

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: