您的位置:首页 > 其它

hdu 1075 What Are You Talking About

2014-06-25 22:36 405 查看

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 13108    Accepted Submission(s): 4160


[align=left]Problem Description[/align]
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book
into English. Can you help him?

 

[align=left]Input[/align]
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines
follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book
part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate
it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated.
A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

[align=left]Output[/align]
In this problem, you have to output the translation of the history book.

 

[align=left]Sample Input[/align]

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

[align=left]Sample Output[/align]
hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

简单的字符串映射,用了map写的。不过之前自己不知道怎么预处理那个“START”,“END”,看了别人的发现了个新东东scanf("%*s");可以读入串,并不用处理串。然后顺序读入那两个串,用mp映射存储。之后的数据直接一行输入,然后新定义一个string保存要检测的字符,得到一个新串。再用find函数,查找mp中是否有映射值。如果存在直接输出映射值,否则输出原串,非字符直接输出。别忘了给mp清空...

代码:

<span style="font-size:14px;">#include<stdio.h>
#include<string.h>
#include<iostream>
#include<cstring>
#include<string>
#include<map>
#define maxn 10000
using namespace std;
map<string,string>mp;
map<string,string>::iterator it;
string a,b;
int main()
{
//freopen("in.txt","r",stdin);
scanf("%*s");
while(cin>>a,a!="END")
{
cin>>b;
mp[b]=a;
}
scanf("%*s");
getchar();
string s,str;
while(getline(cin,s),s!="END")
{
for(int i=0;i<s.length();i++)
{
if(s[i]<'a'||s[i]>'z')
{
it=mp.find(str);
if(it!=mp.end())
cout<<(*it).second;
else
cout<<str;
cout<<s[i];
str="";
}
else
str+=s[i];
}
cout<<endl;
}
mp.clear();
return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: