您的位置:首页 > 其它

Exponentiation - POJ 1001 高精度

2014-06-25 16:32 531 查看
Exponentiation

Time Limit: 500MSMemory Limit: 10000K
Total Submissions: 132745Accepted: 32433
Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


题意:计算a的b次方,结果要求把前面的0和后面的0都去掉。

思路:用J***A的高精度比较方便。

AC代码如下:

import java.util.Scanner;
import java.math.BigDecimal;
public class Main
{ public static void main(String [] args)
  { Scanner scan=new Scanner(System.in);
    BigDecimal a,c;
    int b,l,r,len,i,j,m,pos;
    String s;
    while(scan.hasNextBigDecimal())
    { a=scan.nextBigDecimal();
      b=scan.nextInt();
      c=a.pow(b);
      s=c.toString();
      r=s.length()-1;
      for(i=r;i>=0;i--)
      { if(s.charAt(i)=='E')
        { j=i;
    	  m=0;
    	  for(j+=2;j<=r;j++)
    	   m=m*10+s.charAt(j)-'0';
    	  String s2=".";
    	  for(j=1;j<m;j++)
    	   s2+='0';
    	  for(j=0;j<=i-1;j++)
    	   if(s.charAt(j)!='.')
    	    s2=s2+s.charAt(j);
    	  s=s2;
    	  break;
        }
      }
      l=0;r=s.length()-1;
      while(s.charAt(l)=='0')
       l++;
      while(s.charAt(r)=='0')
       r--;
      if(s.charAt(r)=='.')
       r--;
      for(i=l;i<=r;i++)
    	System.out.print(s.charAt(i));
      System.out.println();
    }
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: