您的位置:首页 > 其它

Hdu 3507 Print Article (线性DP)

2014-06-23 20:49 281 查看
Problem Description

Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.

One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost



M is a const number.

Now Zero want to know the minimum cost in order to arrange the article perfectly.



Input

There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤ 500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.



Output

A single number, meaning the mininum cost to print the article.



Sample Input

5 5
5
9
5
7
5




Sample Output

230




Author

Xnozero


题意略;
思路:本题是比较基本的线性规划
状态转移方程为: dp[i] = min(dp[j] + (sum[i]-sum[j])^2 + m) (j < i);
性质类似于四边形不等式
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define hehe cout<<"shabi"<<endl

long long dp[500010],sum[500010];

int m,n,s[500010],date;
void dpe()
{
    long long temp;
    dp[0]=0;
    s[0]=0;
    for (int i=1;i<=n;i++)
    {
        dp[i]=1e18;
        for (int j=s[i-1];j<=i;j++)
        {
            temp=dp[j]+(sum[i]-sum[j])*(sum[i]-sum[j])+m;
            if(dp[i]>=temp)
            {
                s[i]=j;
                dp[i]=temp;
            }
        }
    }
}
int main ()
{
    //freopen ("out.txt","r",stdin);
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        memset(s,0,sizeof(s));
        for (int i=1;i<=n;i++) {
            scanf ("%d",&date);
            sum[i]=sum[i-1]+date;
        }
        dpe();
        printf("%lld\n",dp
);
    }
    
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: