您的位置:首页 > 其它

hdu 4585 Shaolin两种方法(暴力和STL map set)

2014-06-23 20:16 489 查看
转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4585

Problem Description

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is
also taken into account.

When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose
fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.

The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.



Input

There are several test cases.

In each test case:

The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)

The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.

The input ends with n = 0.



Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.



Sample Input

3
2 1
3 3
4 2
0




Sample Output

2 1
3 2
4 2




Source

2013ACM-ICPC杭州赛区全国邀请赛



Recommend

We have carefully selected several similar problems for you: 4846 4845 4844 4843 4842

题意:

有N个依次进入少林, 每次输出, 新进和尚 和 战斗等级与其最接近的旧和尚的ID。 ID , 和 战斗等级都是唯一的。

代码如下:

第一种暴力:





#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
struct man
{
	int id;
	int g;
	int d;
	int num;
} p[100047];
bool cmp1(man a , man b)
{
	return a.g < b.g;
}
bool cmp2(man a , man b)
{
	return a.num < b.num;
}
int test(int a)
{
	if( a < 0)
		a = -a;
	return a;
}
int main()
{
	int n,m,i,j,t;
	while(scanf("%d",&n) && n)
	{
		for(i = 0 ; i < n ; i++)
		{
			scanf("%d%d",&p[i].id,&p[i].g);
			p[i].num = i+1;
		}
		sort(p,p+n,cmp1);//按等级从小到大
		for(i = 0 ; i < n ; i++)
		{
			p[i].d = 1;
			t = 1000000000-p[i].g;
			for(j = i+1 ; j < n ; j++)//找比当先和尚等级高且最接近的
			{
				if(p[i].num > p[j].num)
				{
					t = test(p[j].g - p[i].g);
					p[i].d=p[j].id;
					break;
				}
			}
			for(j = i-1 ; j >= 0 ; j--)//找比当前和尚等级低且最接近的
			{
				if(p[i].num > p[j].num)
				{
					if(t >= test(p[i].g-p[j].g))
					{
							p[i].d = p[j].id;
					}
					break;
				}
			}
		}
		sort(p,p+n,cmp2);//按和尚进少林寺的顺序排
		for(i = 0 ; i < n ; i++)
		{
			printf("%d %d\n",p[i].id,p[i].d);
		}
	}
	return 0;
}





第二种(STL):

代码如下:







#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0x3fffffff
int main()
{
	int id,g,n;
	map<int,int>m;
	set<int>s;
	while(~scanf("%d",&n) && n)
	{
		s.clear ();
		m.clear ();
		s.insert(1000000000);
		m[1000000000]=1;
		for(int i = 0 ; i < n ; i++)
		{
			scanf("%d%d",&id,&g);
			printf("%d ",id);
			set<int>::iterator it = s.lower_bound(g);
			if(it == s.end())
			{
				it--;
				printf("%d\n",m[*it]);
			}
			else
			{
				int t = *it;
				if(it != s.begin())
				{
					it--;
					if(g - (*it) <= t - g)
					{
						printf("%d\n",m[*it]);
					}
					else
					{
						printf("%d\n",m[t]);
					}
				}
				else
				{
					printf("%d\n",m[*it]);
				}
			}
			m[g] = id;
			s.insert(g);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: