您的位置:首页 > 编程语言 > C语言/C++

C++习题 对象数组求最大值

2014-06-21 12:07 597 查看
/*
Description
建立一个对象数组,内放n(<10)个学生的数据(学号、成绩),设立一个函数max,用指向对象的指针作函数参数,在max函数中找出n个学生中成绩最高者,并输出其学号。
Input
n和n个学生的学号、成绩
Output
成绩最高者的学号和成绩
Sample Input
5 101 78.5 102 85.5 103 98.5 104 100.0 105 95.5
Sample Output
104 100.00
*/
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
private:
int num;
double score;
public:
void input();
int getnum()
{
return num;
}
double getscore()
{
return score;
}
};
void Student::input()
{
cin>>num>>score;
}
void max(Student*q,int n)
{
Student*b;
b=q;
int i;
for(i=0; i<n; i++)
{
if(q->getscore()<b->getscore())
{
q=b;
}
b++;
}
cout<<q->getnum()<<" "<<q->getscore()<<endl;
}
int main()
{
void max(Student* ,int);
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=&stud[0];
max(p,n);
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: