您的位置:首页 > 其它

hdu1171 Big Event in HDU 01-背包

2014-06-21 11:07 429 查看
转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1171

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.


Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.


Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1



Sample Output
20 10
40 40


转换为01-背包问题求解:

代码如下:

#include <cstdio>
#include <cstring>
#define N 200047
int f
,val
;
int max(int a,int b)
{
	if(a > b)
		return a;
	else 
		return b;
}
int main()
{
	int t,n,i,j,k,l,sum,x,y;
	
	while(scanf("%d",&n) && n>0 )
	{
		memset(val,0,sizeof(val));
		memset(f,0,sizeof(f));
		sum = 0;l = 0;
		for(i = 0 ; i < n ; i++)
		{
			scanf("%d%d",&x,&y);
			for(int p=0 ; p<y ; p++)//将价值存入数组
			{
				val[l++] = x;
				sum+=x;
			}
		}
		for(i = 0 ; i < l ; i++)//01背包
		{
			for(j = sum/2 ; j >= val[i]; j--)
			{
				f[j] = max(f[j],f[j-val[i]]+val[i]);
			}
		}
		printf("%d %d\n",sum-f[sum/2],f[sum/2]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: