您的位置:首页 > 其它

POJ2481 Cows

2014-06-20 18:42 141 查看
[align=center]Cows[/align]

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 11946Accepted: 3942
Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint
Huge input and output,scanf and printf is recommended.
Source
POJ Contest,Author:Mathematica@ZSU

题意:就是求第i头牛比其他几头牛强壮(满足Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj这个条件就是i号牛比j号牛强壮)。

分析:刚看到这题想到的是将e排下序,然后数下前面大于或小于s的个数就行,不过这题数据太多,超时,所以就想到了树状数组,也就是将e排序,然后看s就行,不过这题要离散化下(还有个坑的地方,可以输入相同的区间,这个必须要单独拿出来处理)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=100010;
int c[MAX];
int count1[MAX];
struct Node
{
int s,e;
int id;
}p[MAX];
bool cmp(Node a,Node b)
{
if(a.e==b.e)
return a.s<b.s;
return a.e>b.e;
}
int lowbit(int x)
{
return x&(-x);
}
void add(int x,int val)
{
while(x<MAX)
{
c[x]+=val;
x+=lowbit(x);
}
}
int sum(int x)
{
int ans=0;
while(x>0)
{
ans+=c[x];
x-=lowbit(x);
}
return ans;
}
int main()
{
int n,i;
while(scanf("%d",&n)==1&&n)
{
for(i=1;i<=n;i++)
{
scanf("%d%d",&p[i].s,&p[i].e);
p[i].id=i;
}
sort(p+1,p+n+1,cmp);
memset(c,0,sizeof(c));
for(i=1;i<=n;i++)
{
p[i].s++;
if(p[i].s==p[i-1].s&&p[i].e==p[i-1].e)          //注意这里
count1[p[i].id]=count1[p[i-1].id];
else
count1[p[i].id]=sum(p[i].s);
add(p[i].s,1);
}
printf("%d",count1[1]);
for(i=2;i<=n;i++)
{
printf(" %d",count1[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: