您的位置:首页 > 其它

HDU 1170 Balloon Comes! 简单的四则运算

2014-06-18 16:01 459 查看

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20600 Accepted Submission(s): 7790



Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.

Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.

Is it very easy?

Come on, guy! PLMM will send you a beautiful Balloon right now!

Good Luck!


Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of
course, we all know that A and B are operands and C is an operator.


Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.


Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2



Sample Output
3
-1
2
0.50


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1170

/*
Balloon Comes! 1170
简单的四则运算 用case 
除法时 不是整数才.2f 否则整数 
4
+ 1 2
- 1 2
* 1 2
/ 1 2 
*/

#include<iostream>
using namespace std;
int main(){
    int n,a,b,t,k;
    char c;
    cin>>n; 

    while(n--)
    {    getchar();
        scanf("%c %d %d",&c,&a,&b); 
        switch(c){
            case '+': printf("%d\n",a+b);break;
            case '-': printf("%d\n",a-b);break;
            case '*': printf("%d\n",a*b);break;
            case '/': 
                    if (a%b)  printf("%.2f\n",float(a)/b);
                        else printf("%d\n",a/b);
                    break;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: