您的位置:首页 > 其它

HDU 2095 find your present (2) 异或

2014-06-18 15:57 399 查看

find your present (2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/1024 K (Java/Others)

Total Submission(s): 16225 Accepted Submission(s): 6156


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card
number of 3, because 3 is the number that different from all the others.

Input
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output
For each case, output an integer in a line, which is the card number of your present.

Sample Input
5
1 1 3 2 2
3
1 2 1
0



Sample Output
3
2


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2095

/*
找出其中奇数个 不同的数字为礼物 

此题的关键就是 : 
若是采用cin输入 消耗的时间 875ms
    采用scanf输入 消耗的时间是 203ms 

*/
#include<iostream>
using namespace std;
int main(){
    int m,n,y,i,x,k;
    while(scanf("%d",&m)&&m)
    {
        scanf("%d",&x);
        k=x;
        for(i=1;i<m;i++)
        {
            scanf("%d",&x);
            k=k^x;
        }
        cout<<k<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: