您的位置:首页 > 其它

poj1035--Spell checker

2014-06-16 10:25 295 查看
Spell checker

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18430 Accepted: 6764
Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 

?deleting of one letter from the word; 

?replacing of one letter in the word with an arbitrary letter; 

?inserting of one arbitrary letter into the word. 

Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 

All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then
write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the
input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

Northeastern Europe 1998

字符串的问题,给出字典,再给出要查找的单词,如果字典中存在该单词输出correct , 如果字典中的单词,增加或修改或删除一个字母可以得到该单词,则输出字典中的那个单词

首先存储下所有的字典,每输入一个单词如果字典中有长度相等的,判断对应的字母是不是相等,记录不相等的个数;如果由相差一个字母(无论正负)的,由短的向长的比较,如果对应字符相同,均向前移一位,如果不同,记录个数,且把长的向前移一位

如果最后记录为1  那么这个单词应该被输出

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node{
int l ;
char str[20] ;
}p[10002];
int k[10002] , top ;
int main()
{
int i , n = 0 ;
char str[20] ;
while(1)
{
scanf("%s", str);
if(str[0] == '#')
break;
strcpy(p
.str,str);
p
.l = strlen(str);
n++ ;
}
while(1)
{
scanf("%s", str);
if(str[0] == '#')
break;
top = 0 ;
int flag = 0 , l = strlen(str) ;
for(i = 0 ; i < n ; i++)
{
int ans = 0 ;
if( strcmp(p[i].str,str) == 0 )
{
printf("%s is correct\n", str);
break;
}
if( fabs(l - p[i].l) == 0 )
{
int j ;
for(j = 0 ; j < l ; j++)
if( str[j] != p[i].str[j] )
ans++ ;
if( ans == 1 )
k[top++] = i ;
}
else if( fabs(l - p[i].l) == 1 )
{
int c = 0 , d = 0 ;
if(l > p[i].l)
{
for(c = 0 ; c < l ; c++)
{
if( str[c] != p[i].str[d] )
ans++ ;
else
d++ ;
}
}
else
{
for(c = 0 ; c < p[i].l ; c++)
{
if( p[i].str[c] != str[d] )
ans++ ;
else
d++ ;
}
}
if(ans == 1)
k[top++] = i ;
}
}
if(i < n )
continue ;
else if(top == 0)
printf("%s: \n", str);
else
{
printf("%s: ", str);
for(i = 0 ; i < top ; i++)
{
if(i == top-1)
printf("%s\n", p[ k[i] ].str );
else
printf("%s ", p[ k[i] ].str );
}
}
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: