您的位置:首页 > 其它

zoj 2744 Palindromes (求回文子序列的个数)

2014-06-15 19:11 302 查看
链接:zoj 2744

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string
is read from left to right as when the string is read from right to left.
Now give you a string S, you should count how many palindromes in any consecutive substring of S.
Input
There are several test cases in the input. Each case contains a non-empty string which has no more than 5000 characters.
Proceed to the end of file.
Output
A single line with the number of palindrome substrings for each case.
Sample Input
aba

aa

Sample Output
4

3

求回文子序列的个数,如 aba 的回文子序列有 a, b, a, aba.

解析:一个序列,若一个序列中间的两个连续字符或三个连续字符的子序列不回文,则其肯定不回文

代码:
#include<stdio.h>
#include<string.h>
int main()
{
    char s[5005];
    int i,l,r,t,n;
    while(scanf("%s",s)!=EOF){
        t=n=strlen(s);
        for(i=0;i<n;i++){
            l=i;
            r=i+1;
            while(l>=0&&r<n){
                if(s[l--]==s[r++])
                    t++;
                else
                    break;
            }
        }
        for(i=0;i<n;i++){
            l=i;
            r=i+2;
            while(l>=0&&r<n){
                if(s[l--]==s[r++])
                    t++;
                else
                    break;
            }
        }
        printf("%d\n",t);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: