您的位置:首页 > 其它

POJ 1753 Flip Game (DFS 太暴力了!)

2014-06-14 20:22 585 查看
Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces,
thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible"
(without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4


题意==:翻棋子,当出现全黑或是全白的时候停止,每次翻转连带着上、下、左、右一块翻转(如果有的话)。问实现全白或是全黑所需最少步数。。。

用的DFS的方法(Hypo教的),通过这个题才见识到DFS原来可以这么暴力,对DFS的认识又上了一个新的层次。。。

DFS是模拟栈来实现的,一开始是从第一个到最后一个,每一个都入栈储存起来,然后再从最后一个往外吐。

往外吐得时候还要判断翻转了当前这个的状态是否全黑或全白,然后从它到最后的所有棋子再入栈储存,再出栈进行判断,从它到最后的所有棋子再入栈储存,再出栈判断,从它到最后的所有棋子再入栈储存,再出栈判断。。。。。一直第一个。TM咋么可以这么暴力,粗略的计算了一下,总共就16个棋子,最后一个貌似是被翻转了2^16次。

PS:POJ2965解题报告

代码的运行方式 是从第一个开始,一列一列的入栈,当然一行一行的也行啊。。上代码。

#include <stdio.h>

const int inf=9999999;
char s[10];
int map[10][10],i,j;
int ans=inf;

int panduan()
{
    int x=map[0][0];
    for (i=0; i<4; i++)
    {
        for (j=0; j<4; j++)
        {
            if (map[i][j]!=x)
                return 0;
        }
    }
    return 1;
}

void fan (int x,int y)
{
    map[x][y]=!map[x][y];
    if (x - 1 >= 0)
        map[x-1][y]=!map[x-1][y];
    if (x + 1 < 4)
        map[x+1][y]=!map[x+1][y];
    if (y - 1 >= 0)
        map[x][y-1]=!map[x][y-1];
    if (y + 1 < 4)
        map[x][y+1]=!map[x][y+1];
}

int dfs (int x,int y,int t)
{
    if ( panduan())
    {
        if (ans > t)
            ans = t ;
        return 0;
    }
    if (x >= 4 || y >= 4)
        return 0;
    int nx,ny;
    nx = (x + 1)%4;
    ny = y + ( x + 1 ) / 4;

    dfs (nx,ny,t);
    fan (x,y);

    dfs (nx,ny,t+1);
    fan (x,y);

    return 0;
}

int main ()
{
    for (i=0; i<4; i++)
    {
        scanf ("%s",s);
        for (j=0; j<4; j++)
        {
            if (s[j]=='b')
                map[i][j]=0;
            else
                map[i][j]=1;
        }
    }
    dfs (0,0,0);

    if (ans == inf )
        printf ("Impossible\n");
    else printf ("%d\n",ans);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: