您的位置:首页 > 大数据 > 人工智能

HDU 1023 Train Problem II(卡特兰数)

2014-06-11 17:46 405 查看

Train Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5603 Accepted Submission(s): 3030



点击打开题目链接

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.



Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.



Output
For each test case, you should output how many ways that all the trains can get out of the railway.



Sample Input
1
2
3
10




Sample Output
1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.




Author
Ignatius.L


Recommend

题目说一堆火车有序到站,问一共有多少种进站出站的情况,就是典型的卡特兰数的应用(出栈次序:一个栈(无穷大)的进栈序列为1,2,3,…,n,有多少个不同的出栈序列)

对于卡特兰数请看/article/1569303.html

下面代码实现:

#include <iostream>
#include<memory.h>
#include<stdio.h>
#define max 100
using namespace std;
void mul(int a[],int b)
{
    int i,mu=0;
    for(i=max-1;i>=0;i--)
    {
        mu+=b*a[i];
        a[i]=mu%10000;
        mu/=10000;
    }
}
void div(int a[],int b)
{
    int i,d=0;
    for(i=0;i<max;i++)
    {
        d=d*10000+a[i];
        a[i]=d/b;
        d%=b;
    }
}
int main()
{
    int i,a[max+1][max],n;
    memset(a[1],0,sizeof(a[0])*max);
    a[1][max-1]=1;//倒着存放,避免了最后的倒序
    for(i=2;i<101;i++)
    {
        memcpy(a[i],a[i-1],sizeof(int)*max);//把a[i-1]赋值给a[i];
        mul(a[i],4*i-2);
        div(a[i],i+1);
    }
    while(cin>>n&&(n!=-1))
    {
        for(i=0;i<max&&a
[i]==0;i++);
        cout<<a
[i++];
        for(;i<max;i++)
            printf("%04d",a
[i]);
        cout<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: