您的位置:首页 > 其它

POJ训练计划3295_Tautology(构造/类栈处理)

2014-06-10 23:35 423 查看
Tautology

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9156 Accepted: 3502
Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the
value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0

Sample Output
tautology
not

Source

Waterloo Local Contest, 2006.9.30

解题报告

久违的1A。。。感动得哭了。。。

临睡之前1A让我难以入睡。。。

倒着对字符串处理,对于小写的压栈处理,对于大写的判断是一元操作和二元操作,对于栈顶和栈顶下面一个元素操作。。。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
char str[1100];
int stac[110000],top=-1;
int main()
{
int i,j,k,l,p, q, r, s, t,n,m;
while(cin>>str)
{
if(str[0]=='0')break;
n=0,m=0;
int l=strlen(str);
for(p=0; p<=1; p++)
{
for(q=0; q<=1; q++)
{
for(r=0; r<=1; r++)
{
for(s=0; s<=1; s++)
{
for(t=0; t<=1; t++)
{
for(i=l;i>=0;i--)
{
if(str[i]>='A'&&str[i]<='Z')
{
if(str[i]=='N')
stac[top]=!stac[top];
else if(str[i]=='K')
{
stac[top-1]=stac[top]&stac[top-1];
top--;
}
else if(str[i]=='A')
{
stac[top-1]=stac[top]|stac[top-1];
top--;
}
else if(str[i]=='C')
{
if(!stac[top]&&stac[top-1])
stac[top-1]=0;
else stac[top-1]=1;
top--;
}
else if(str[i]=='E')
{
stac[top-1]=stac[top]==stac[top-1]?1:0;
top--;
}
}
else
{
if(str[i]=='p')
stac[++top]=p;
else if(str[i]=='q')
stac[++top]=q;
else if(str[i]=='r')
stac[++top]=r;
else if(str[i]=='s')
stac[++top]=s;
else if(str[i]=='t')
stac[++top]=t;
}
}
if(stac[top]==1)
{
n++;
}
else m++;
}
}
}
}
}
if(m==0)cout<<"tautology"<<endl;
else cout<<"not"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: