您的位置:首页 > 其它

UVa 575 Skew Binary 歪斜二进制

2014-06-08 17:43 591 查看
呵呵,这个翻译还是很直白的嘛,大家意会就好。

第一次看到这个高大上题目还是有点小害怕的,还好题没有做过深的文章。

只要按照规则转化成十进制就好了,而且题目本身也说了最大不超过一个int的范围(2^31-1 ==
2147483647)。

直接位运算就好了。



Skew Binary

When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,



When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example,



In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For
example,



The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to
do with the current problem.)

Input

The input file contains one or more lines, each of which contains an integer n. If n =
0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output

For each number, output the decimal equivalent. The decimal value of n will be at most 231 -
1 = 2147483647.

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0


Sample Output

44
2147483646
3
2147483647
4
7
1041110737


Miguel A. Revilla

1998-03-10
AC代码:

//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char SkBinary[35];

void Reverse(char s[], int l);

int main(void)
{
#ifdef LOCAL
freopen("575in.txt", "r", stdin);
#endif

while(gets(SkBinary) && SkBinary[0] != '0')
{
int l = strlen(SkBinary);
Reverse(SkBinary, l);
int i, n = 0;
for(i = 0; i < l; ++i)
{
if(SkBinary[i] == '0')
continue;
if(SkBinary[i] == '1')
n += (1 << (i + 1)) - 1;
if(SkBinary[i] == '2')
n += (1 << (i + 2)) - 2;
}
cout << n << endl;
}
return 0;
}
//用来反转数组
void Reverse(char s[], int l)
{
int i;
char t;
for(i = 0; i < l / 2; ++i)
{
t = s[i];
s[i] = s[l - i -1];
s[l - i -1] = t;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: