您的位置:首页 > 其它

杭电1178--Heritage from father

2014-06-07 17:44 519 查看
[align=left]Problem Description[/align]
Famous Harry Potter,who seemd to be a
normal and poor boy,is actually a wizard.Everything changed when he
had his birthday of ten years old.A huge man called 'Hagrid' found
Harry and lead him to a new world full of magic power.

If you've read this story,you probably know that Harry's parents
had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the
bank hold up by Goblins). And they stepped into the room which
stored the fortune from his father.Harry was astonishing ,coz there
were piles of gold coins.

The way of packing these coins by Goblins was really special.Only
one coin was on the top,and three coins consisted an triangle were
on the next lower layer.The third layer has six coins which were
also consisted an triangle,and so on.On the ith layer there was an
triangle have i coins each edge(totally i*(i+1)/2).The whole heap
seemed just like a pyramid.Goblin still knew the total num of the
layers,so it's up you to help Harry to figure out the sum of all
the coins.

Input
The input will consist of some
cases,each case takes a line with only one integer
N(0<N<2^31).It ends with a single
0.

Output

对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

Sample Input
1

3

0
Sample Output
1.00E0

1.00E1

Hint
Hint
when N=1 ,There is 1 gold coins. when N=3 ,There is 1+3+6=10 gold
coins.

 

 

//////////////////////////////////////////////////////////////////////////////

# include<stdio.h>

int main()

{

      
int m;

      
double n;

      
while(scanf("%lf",&n),n!=0)

      
{

             
n=n*(n+1)*(n+2)/6;

             
m=0;

             
while(n>=10)

             
{

                    
n/=10;

                    
m++;

             
}

             
printf("%.2fE%d\n",n,m);

      
}

      
return 0;

}

 

涉及两个求和公式:

1+2+3+4+5+……=(n+1)*n/2;
平方和公式

1*1+2*2+3*3+4*4+……=n(n+1)(2n+1)/6;

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: