您的位置:首页 > 其它

杭电1171--Big Event in HDU(多重…

2014-06-07 17:43 309 查看
Problem
Description

Nowadays, we all know that Computer
College is the biggest department in HDU. But, maybe you don't know
that Computer College had ever been split into Computer College and
Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time,
it is a trouble thing too. All facilities must go halves. First,
all facilities are assessed, and two facilities are thought to be
same if they have the same value. It is assumed that there is N
(0<N<1000) kinds of facilities
(different value, different kinds).

Input
Input contains multiple test cases. Each
test case starts with a number N (0 < N
<= 50 -- the total number of different facilities).
The next N lines contain an integer V
(0<V<=50 --value of facility) and an
integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are
different.

A test case starting with a negative integer terminates input and
this test case is not to be processed.

Output
For each case, print one line containing
two integers A and B which denote the value of Computer College and
Software College will get respectively. A and B should be as equal
as possible. At the same time, you should guarantee that A is not
less than B.

Sample Input
2

10 1

20 1

3

10 1

20 2

30 1

-1

Sample Output

20 10 40
40

 

# include<stdio.h>

# include<string.h>

int V,f[200000];

void ZeroOnePack(int cost,int weight)

{

      
int v;

      
for(v=V;v>=cost;v--)

             
if(f[v]<f[v-cost]+weight)

                    
f[v]=f[v-cost]+weight;

}

void CompletePack(int cost,int weight)

{

      
int v;

      
for(v=cost;v<=V;v++)

             
if(f[v]<f[v-cost]+weight)

                    
f[v]=f[v-cost]+weight;

}

void MultiplePack(int cost,int weight,int amount)

{

      
int k;

      
if(cost*amount>=V)

      
{

             
CompletePack(cost,weight);

             
return ;

      
}

      
k=1;

      
while(k<amount)

      
{

             
ZeroOnePack(k*cost,k*weight);

             
amount=amount-k;

             
k=k*2;

      
}

      
ZeroOnePack(amount*cost,amount*weight);

}

 

int main()

{

      
int i,num,w[60],n[60],sum;

      
while(scanf("%d",&num))

      
{

             
if(num<=0)

                    
break;

             
sum=0;

             
for(i=1;i<=num;i++)

             
{

                    
scanf("%d%d",&w[i],&n[i]);

                    
sum+=w[i]*n[i];

             
}

             
V=sum/2;

             
memset(f,0,sizeof(f));

             
for(i=1;i<=num;i++)

                    
MultiplePack(w[i],w[i],n[i]);

             
printf("%d %d\n",sum-f[V],f[V]);

      
}

      
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: