您的位置:首页 > 其它

hdu 3336 Count the string

2014-06-07 17:35 323 查看


Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4239 Accepted Submission(s): 1977



Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab


Sample Output

6


KMP+DP

next[i]=j表示0到j的字符串和i-j+1到i这段字符串相等。

dp[i]=dp[next[i]]+1;这个位置的跟之前的有过多少次匹配,仅仅要在原基础上加1就可以。

#include"stdio.h"
#include"string.h"
#define N 200005
#define M 10007
char s
;
int dp
,p
;
void getnext(int m,char *t)
{
int i=0,j=-1;
p[0]=-1;
while(i<m)
{
if(j==-1||t[i]==t[j])
{
i++;
j++;
p[i]=j;
}
else
j=p[j];
}
}
int main()
{
int T,n,i;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
scanf("%s",s);
getnext(n,s);
int ans=0;
for(i=1;i<=n;i++)
{
dp[i]=dp[p[i]]+1;
ans+=dp[i];
ans%=M;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: