您的位置:首页 > 其它

Minimum Transport Cost (HDU 1385)

2014-06-07 12:50 211 查看

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7108 Accepted Submission(s): 1817



Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN

b1 b2 ... bN

c d

e f

...

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :

Path: c-->c1-->......-->ck-->d

Total cost : ......

......

From e to f :

Path: e-->e1-->..........-->ek-->f

Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0


Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17


一开始我还以为floyd算法会直接输出字典序最小的最短路,后来发现我错了%>_<%,
需要自己再判断一下,,好,get√
#include<stdio.h>
#include<string.h>
const int INF = 100000000;
int d[110][110],path[110][110];
int main()
{
    int n,c,i,j,k;

    while(~scanf("%d", &n), n)
    {
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                d[i][j] = INF;
                path[i][j] = j; //初始化路径
                scanf("%d", &c);
                if(c != -1) d[i][j] = c;
            }
        }
        int m[110];
        for(i=1; i<=n; i++)
            scanf("%d", m+i);
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                if(d[i][j] >= 0) d[i][j] += m[j];
        for(k=1; k<=n; k++)
          for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                if(d[i][k]+d[k][j] < d[i][j])
                   d[i][j] = d[i][k]+d[k][j], path[i][j] = path[i][k];
                else if(d[i][k]+d[k][j] == d[i][j])
                   path[i][j] = (path[i][j] < path[i][k] ? path[i][j] : path[i][k]);//选出字典序最小的路径
            }
        int a,b;
        while(~scanf("%d%d", &a,&b))
        {
            if(a==-1 && b==-1) break;
            printf("From %d to %d :\nPath: ", a,b);
            i = a;
            while(i != b)
            {
                printf("%d-->", i);
                i = path[i][b];
            }
            printf("%d\n", b);
            printf("Total cost : %d\n\n", d[a][b]-m[b]);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: