您的位置:首页 > 产品设计 > UI/UE

POJ1679_The Unique MST(次小生成树)

2014-06-07 12:01 375 查看
The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19445 Accepted: 6794
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 

1. V' = V. 

2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ

解题报告

判断是否存在唯一的最小生成树。

也就是判断有没有次小生成树。

我用Kru写的。先求出一次最小生成树,记录下用到的边,然后依次删除每一条边再求一次最小生成树,如果存在最小生成树就说明有次小生成树。。。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <stdlib.h>

using namespace std;
struct ed
{
int u,v,w;
} edge[110*110];
int cmp(ed a,ed b)
{
return a.w<b.w;
}
int n,m;
int B[110];
int fine(int x)
{
if(x!=B[x])
B[x]=fine(B[x]);
return B[x];
}
int vis[110*110];
int kru(int x)
{
int i,j,ans=0,k=0;
for(i=0; i<n; i++)
B[i]=i;
if(x==-1)
{
for(i=0; i<m; i++)
{
int xx=fine(edge[i].u);
int yy=fine(edge[i].v);
if(xx!=yy)
{
k++;
B[xx]=yy;
ans+=edge[i].w;
vis[i]=1;
}
}
return ans;
}
else
{
for(i=0; i<m; i++)
{
if(i!=x)
{
int xx=fine(edge[i].u);
int yy=fine(edge[i].v);
if(xx!=yy)
{
k++;
B[xx]=yy;
ans+=edge[i].w;
}
}
}
if(k==n-1)
return ans;
}
}
int main()
{
int i,j,t,a,b,c;
scanf("%d",&t);
while(t--)
{
memset(edge,0,sizeof(edge));
memset(vis,0,sizeof(vis));
scanf("%d%d",&n,&m);
for(i=0; i<m; i++)
{
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
}
sort(edge,edge+m,cmp);
int minst=kru(-1);
int cnt=0;
for(i=0; i<m; i++)
{
if(vis[i])
{
int ans=kru(i);
if(ans==minst)
{
cnt=1;
break;
}
}
}
if(cnt)
printf("Not Unique!\n");
else
printf("%d\n",minst);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: