您的位置:首页 > 其它

HDU 1013_Digital Roots(大数&模拟)

2014-06-06 21:11 429 查看

Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 47146 Accepted Submission(s): 14605



点击打开题目

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.



Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.



Output
For each integer in the input, output its digital root on a separate line of the output.



Sample Input
24
39
0




Sample Output
6
3




Source
Greater New York 2000

不断把各个位上的数相加,直到得到一个个位数。

代码:

#include <iostream>
#include<cstdio>
using namespace std;
long long int check(long long int n)
{
    long long int a;
    long long int s=0;
    for(;;)
    {
        a=n%10;
        s=s+a;
        if(n/10==0)
            break;
        n=n/10;
    }
    return s;
}
int main()
{
    long long int i;
    long long int s;
    char c[1000];
    while(scanf("%s",c)!=EOF&&c[0]!='0')//字符串输入解决大数问题
    {
        s=0;
       for(i=0;c[i]!='\0';i++)
       {
           s=s+c[i]-'0';//变为整数
       }
        while(s/10!=0)//循环模拟过程,求解
        {
            s=check(s);
        }
        cout<<s<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: