您的位置:首页 > 大数据 > 人工智能

POJ2585_Window Pains(拓扑排序)

2014-06-06 19:00 411 查看
Window Pains

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1548 Accepted: 767
Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows
and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows: 
11..
11..
....
....
.22.
.22.
....
....
..33
..33
....
....
....
44..
44..
....
....
.55.
.55.
....
....
..66
..66
....
....
....
77..
77..
....
....
.88.
.88.
....
....
..99
..99
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation
would be:
122?
122?
????
????
If window 4 were then brought to the foreground:
122?
442?
44??
????
. . . and so on . . . 

Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly.
And this is where you come in . . .
Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
Start line - A single line: 

START 

Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers
on each line will be delimited by a single space. 

End line - A single line: 

END 

After the last data set, there will be a single line: 

ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 

THESE WINDOWS ARE BROKEN 

Sample Input
START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output
THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

Source

South Central USA 2003

解题报告

其实我想说NO zuo NO die 。。。

明明计算机不稳定,非得运行9个窗体。。。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int mmap[10][10],tp[5][5],n;
string num[5][5];
int h[10],d[10];
void topsort()
{
int i,j,u,cnt=0,k;
for(i=0; i<n; i++)
{
u=0;
for(j=1; j<=9; j++)
{
if(h[j]&&d[j]==0)
{
d[j]--;
cnt++;
u=j;
for(k=1; k<=9; k++)
{
if(mmap[u][k])
{
d[k]--;
}
}
break;
}
}
}
if(cnt!=n)
cout<<"THESE WINDOWS ARE BROKEN"<<endl;
else cout<<"THESE WINDOWS ARE CLEAN"<<endl;
}

int main()
{
int i,j,k;
char s[11],e[5];
for(i=0; i<4; i++)
for(j=0; j<4; j++)
num[i][j].erase();
for(k=1; k<=9; k++)
{
i=(k-1)/3;
j=(k-1)%3;
num[i][j]+=char(k+'0');
num[i][j+1]+=char(k+'0');
num[i+1][j]+=char(k+'0');
num[i+1][j+1]+=char(k+'0');
}
while(cin>>s)
{
n=0;
memset(tp,0,sizeof(tp));
memset(mmap,0,sizeof(mmap));
memset(h,0,sizeof(h));
memset(d,0,sizeof(d));
if(strcmp(s,"ENDOFINPUT")==0)break;
for(i=0; i<4; i++)
{
for(j=0; j<4; j++)
{
cin>>tp[i][j];
if(!h[tp[i][j]])
{
h[tp[i][j]]=1;
n++;
}
int sz=num[i][j].length();
for(k=0; k<sz; k++)
{
if(!mmap[tp[i][j]][num[i][j][k]-'0']&&tp[i][j]!=num[i][j][k]-'0')
{
mmap[tp[i][j]][num[i][j][k]-'0']=1;
d[num[i][j][k]-'0']++;
}
}
}
}
cin>>e;
topsort();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: