您的位置:首页 > 其它

【POJ】1007 DNA Sorting

2014-06-06 11:22 363 查看
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence
``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it
is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number
of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal
order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


这个题目的意思并不是求DNA序列的ATCG配对,
而是求这些序列的稳定程度由低到高排序。
稳定程度指的是这个字符数组中的逆序数之和。
知道这个之后就很简单了。
要注意的是,排序的时候调用qsort或者sort函数都可以,
冒泡排序的话可能会TLE。

怒贴代码:
#include<stdio.h>
#include<iostream>
#include<stdlib.h>
#include<algorithm>

using namespace std;

struct DNA
{
char atcg[55];
int cas;
};
DNA dna[110];

bool cmp(DNA a,DNA b)
{
return a.cas<b.cas;
}

int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<m;i++)
{
scanf("%s",dna[i].atcg);
dna[i].cas=0;
for(int j=0;j<n-1;j++)
for(int k=j+1;k<n;k++)
{
if(dna[i].atcg[j]>dna[i].atcg[k])
dna[i].cas++;
}
}
sort(dna,dna+m,cmp);
for(int i=0;i<m;i++)
{
printf("%s\n",dna[i].atcg);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: