您的位置:首页 > 其它

POJ 1961-Period (KMP)

2014-06-05 20:10 225 查看

Period


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

For each prefix of a given string S with N characters (each character has an
ASCII code between 97 and 126, inclusive), we want to know whether the prefix
is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K
> 1 (if there is one) such that the prefix of S with length i can be written as AK ,
that is A concatenated K times, for some string A. Of course, we also want to
know the period K.

输入

The input file consists of several test cases. Each test case consists of two
lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.
The second line contains the string S. The input file ends with a line, having the
number zero on it.

输出

For each test case, output “Test case #” and the consecutive test case
number on a single line; then, for each prefix with length i that has a period K >
1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.

示例输入

3
aaa
12
aabaabaabaab
0


示例输出

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4


提示

来源

Southeastern European Regional Programming Contest

示例程序

KMP的简单运用。求字符串的最大子串。

#include <stdio.h>
char s[1000010];
int next[1000010],n;
int getnext( )
{
int i=0,j=-1;
next[0]=-1;
while(i<n)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int main( )
{
int i;
int k=0;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
k++;
scanf("%s",s);
getnext( );
printf("Test case #%d\n",k);
for( i=2; i<=n; i++)
{
if(i%(i-next[i])==0)
{
if(i/(i-next[i])>1)
printf("%d %d\n",i,i/(i-next[i]));
}
}
printf("\n");
}
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: