您的位置:首页 > 其它

Joseph - POJ 1012 打表

2014-06-05 12:13 246 查看
Joseph

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 47228Accepted: 17791
Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved.
Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output

The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0

Sample Output
5
30


题意:顺时针数,让第几个人出去,最后要留下前k个。

思路:打表。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{ int num[]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
  int i,j,k;
  while(~scanf("%d",&k) && k>0)
   printf("%d\n",num[k]);
}


打表代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int r[14];
bool solve(int k,int i)
{ int n=k*2,x=0;
  while(n>k)
  { x=(x+i-1)%n;
	if(x<k) return false;
    n--;
  }
  return true;
}
int main(){
	int i,j,k;
	for(k=1;k<14;k++)
	 for(i=k+1;;i+=k+1)
     { if(solve(k,i))
       { r[k]=i;
         break;
       }
       else if(solve(k,i+1))
       { r[k]=i+1;
		 break;
       }
      }
	for(i=1;i<=13;i++)
	 printf("%d %d\n",i,r[i]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: