您的位置:首页 > 其它

hdoj 1306 String Matching

2014-06-02 12:31 281 查看
题意是找到最大的覆盖数,可以移动一个字符串,使他与另外一个字符串依次覆盖(向左一位一位的挪, 向右一位一位的挪),找的最大值即可,最后要化简

Problem Description
It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY

MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY

MARSUPIAL

with two common letters (A and R), but the best is:

CAPILLARY

MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2

-----------------------------

length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.



Sample Input
The input for your program will be a series of words, two per line, until the end-of-file flag of -1.

Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example:

CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1

The words will all be uppercase.




Sample Output
Print the value for appx() for each pair as a reduced fraction, like this:

appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1


#include<stdio.h>
#include<string.h>
int gcm( int a, int b )
{
	int t;
	while( a!= 0 )
	{
		t = b%a;
		b = a;
		a = t;
	}
	return b;
}
int main()
{
	char s[2002], a[1001], b[1001];
	int cou, i, j;
	while( gets(s) )
	{
		if( s[0] == '-'&&s[1]=='1' ) break;
		int l = strlen(s);
		i = j = 0;
		while( s[i] != ' '&&i<=l-1 )
		{
			a[j++] = s[i++];
		}
		a[j] = '\0';
		int la = j;
		i+=1; j = 0;
		while( i<=l-1 )
		{
			b[j++] = s[i++];
		}
		b[j] = '\0';
		int lb = j;
		int k, max = 0;
		for( i = 0; i < la; i ++ )
		{
			cou = 0;
			for( j = 0, k = i; k<la&&j < lb; j ++, k++ )
			{
				if( a[k] == b[j] )
				++cou;
			}
			if( max < cou )
			max = cou;
		}
		for( j = 0; j < lb; j ++ )
		{
			cou = 0;
			for( i = 0, k = j; i < la&&k < lb; i++, k++ )
			{
				if( a[i] == b[k] )
				++cou;
			}
			if( max < cou )
			max = cou;
		}
		printf( "appx(%s,%s) = ", a, b );
		max*=2;
		if( max == 0 )
		printf( "0\n" );
		else if( max % (la+lb) == 0 )
		printf( "1\n" );
		else
		{
		int gc = gcm( max, la+lb );
		printf( "%d/%d\n", max/gc, (la+lb)/gc );
	}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: