您的位置:首页 > 其它

POJ训练计划2503_Babelfish(二分)

2014-06-01 20:47 316 查看
Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 30751 Accepted: 13244
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears
more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output
cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

解题报告

本来写哈希来着,超时了,就改成二分。。。

谁知道很久没用sort的cmp函数,给忘光了。。。罪过呀。。。

sad。。。

换成qsort又不会写了。。。

WA了好几次。。。sad,原因是把字符串长度开小了,一直不知道,还以为哪里写错了。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
char s1[15];
char s2[15];
}str[100010];
int cmp(const void *p1,const void *p2)
{
return strcmp((*(node *)p1).s2,(*(node *)p2).s2)>0?1:-1;
}
int main()
{
char sh[30];
int i,j,m=0;
while(gets(sh)!=NULL)
{
if(sh[0]=='\0')break;
int k=0,c=0;
for(i=0;sh[i]!='\0';i++)
{
if(sh[i]==' ')
{
k=1;
str[m].s1[i]=0;
continue;
}
if(!k)
str[m].s1[i]=sh[i];
else str[m].s2[c++]=sh[i];
}
str[m].s2[c]=0;
m++;
}
qsort(str,m,sizeof(str[0]),cmp);
char ch[20];
while(~scanf("%s",ch))
{
int l=0,r=m-1;
int f=0;
while(l<=r)
{
int mid=(l+r)/2;
if(strcmp(str[mid].s2,ch)<0)
l=mid+1;
else if(strcmp(str[mid].s2,ch)==0)
{
printf("%s\n",str[mid].s1);
f=1;
break;
}
else r=mid-1;
}
if(f==0)
printf("eh\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: