您的位置:首页 > 编程语言 > Java开发

POJ1035-Spell checker(java版)

2014-06-01 14:49 281 查看
Spell checker

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 18361Accepted: 6739
Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then
write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the
input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

水题:
import java.util.Arrays;
import java.util.Scanner;

public class P1035_SpellChecker {

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(System.in);
String[] dic= new String[10001];
int[] index=new int[10000];
//		String[] check=new String[50];
int i=0;
int size=0;
while(true){
dic[i]=new String();
if((dic[i]=in.next()).equals("#")){
size=i;
i=0;
while(true){
String temp=null;
int po=0;
int flag=0;
boolean bool=true;
Arrays.fill(index, -1);
if((temp=in.next()).equals("#"))
break;
for(int j=0;j<size;j++){
if(temp.length()>dic[j].length()){
flag=comp(temp,dic[j]);
}else{
flag=comp(dic[j],temp);
}
if(flag==2)continue;
if(flag==1){
index[po++]=j;
continue;
}
if(flag==3){
bool=false;
System.out.println(temp+" is correct");
Arrays.fill(index, -1);
}
}
if(bool){
System.out.print(temp+":");
for(int j=0;j<10000;j++){
if(index[j]==-1)break;
else System.out.print(" "+dic[index[j]]);
}
System.out.println();
}
i++;
}
break;
}
i++;
}
}
public static int comp(String str1,String str2){
int ab=Math.abs(str1.length()-str2.length());
int len=str2.length();
if(ab>=2)
return 2;
else if(ab==1){
for(int k=0;k<len;k++){
if(str1.charAt(k)!=str2.charAt(k)){
if(str1.substring(k+1).endsWith(str2.substring(k)))
return 1;
else return 2;
}
if(k==len-1)return 1;
}
}else{
if(str1.equals(str2))return 3;
for(int k=0;k<len;k++){
if(str1.charAt(k)!=str2.charAt(k)){
if(str1.substring(k+1).endsWith(str2.substring(k+1)))
return 1;
else return 2;
}
if(k==len-1)return 1;
}
}
return 2;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: