您的位置:首页 > 其它

I Think I Need a Houseboat - POJ 1005 水题

2014-05-31 22:40 357 查看
I Think I Need a Houseboat

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 85226Accepted: 36898
Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi
River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The
semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)



Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in
miles. The Y coordinate will be non-negative. (0,0) will not be given.
Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within
the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”
Sample Input
2
1.0 1.0
25.0 0.0

Sample Output
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.


题意:一个半圆每年增加50平方公里,问某个点第几年沦陷……

思路:加上一个ceil,取大于等于它的最小整数。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
const double pi=3.14159265358979;
using namespace std;
int main()
{ int T,t,i,j,k;
  double a,b,r;
  scanf("%d",&T);
  for(t=1;t<=T;t++)
  { scanf("%lf%lf",&a,&b);
    r=a*a+b*b;
    k=(int)ceil(pi*r/100);
    printf("Property %d: This property will begin eroding in year %d.\n",t,k);
  }
  printf("END OF OUTPUT.\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: