您的位置:首页 > 其它

POJ训练计划3349_Snowflake Snow Snowflakes(哈希)

2014-05-31 20:35 441 查看
Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 29924 Accepted: 7868
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake
has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six
integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms.
For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output
Twin snowflakes found.

Source

CCC 2007

解题报告

判断是否有两个雪花一样,不过好像不用判断是不是同构雪花。。。

所以就直接用累加取余。用链地址法处理冲突。。。

这是直接用静态数组来完成链地址。嫌链表不好写,如果题目内存有限,就要用链表了。。。(链表忘光了。。。sad。。。)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
int dx[7];
}num;
int head[5000];
node hash[5000][5000];
int main()
{
int n,i,j,ok=0,sum,lll;
scanf("%d",&n);
for(i=0;i<n;i++)
{
sum=0;
for(j=0;j<6;j++)
{
scanf("%d",&num.dx[j]);
sum=(sum+num.dx[j])%4997;
}
sort(num.dx,num.dx+6);
if(ok==0)
{
for(j=0;j<head[sum];j++)
{
lll=0;
for(int k=0;k<6;k++)
{
if(hash[sum][j].dx[k]!=num.dx[k])
{
lll=1;
break;
}
}
if(!lll)
{
ok=1;
break;
}
}
}
hash[sum][head[sum]++]=num;
}
if(ok)cout<<"Twin snowflakes found."<<endl;
else cout<<"No two snowflakes are alike."<<endl;
}


自己又尝试用STL的vector写了下。。。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;
struct node
{
int d[10];
};
vector<node>hash[100010];
int main()
{
int n,f=0,sum,i,j,lll=0,ok=0;
node num;
scanf("%d",&n);

for(i=0; i<n; i++)
{
sum=0;
for(j=0; j<6; j++)
{
scanf("%d",&num.d[j]);
sum=(sum+num.d[j]%14997)%14997;
}
sort(num.d,num.d+6);
if(ok==0)
{
int sz=hash[sum].size();
for(j=0; j<sz; j++)
{
lll=0;
for(int k=0; k<6; k++)
if(hash[sum][j].d[k]!=num.d[k])
{
lll=1;
break;
}
if(!lll)
{
ok=1;
break;
}
}
hash[sum].push_back(num);
}
}
if(ok)cout<<"Twin snowflakes found."<<endl;
else cout<<"No two snowflakes are alike."<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: