您的位置:首页 > 其它

POJ 1552 Doubles

2014-05-31 10:23 239 查看
Doubles

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 18840Accepted: 10857
Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same
list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22


your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with
the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
Output
The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0

此题,不是按照正常输入来的,没有给出每组数据需要输出的具体数是多少,每组数据输入的数是0时,那么这组数据输入完毕,如果输入是-1的时候,那么整个程序就结束。
输入-1的时候简单只要是while(scanf("%d",&n)!=EOF&&n!=-1)即可,比较难的地方是在输入以0为结尾时,这组数据输入结束,这样的功能是在while函数内部来实现的。
这道题不用排序也可以,冒泡排序: for(i=1;i<=k;i++) for(j=1;j<=k-1-i;j++).

#include <stdio.h>
#include <memory.h>
int a[20];
int main (void)
{
//  freopen("1552.txt","r",stdin);
int n,m,k=0,i,j,t,sum=0;
while(scanf("%d",&n)!=EOF&&n!=-1)
{
a[++k]=n;
if(n==0)
{
for(i=1;i<=k;i++)
{
for(j=1;j<=k-1-i;j++)
{
if(a[j]>a[j+1])
{
t=a[j];
a[j]=a[j+1];
a[j+1]=t;
}
}
}
//  for(i=1;i<k;i++)
//    printf("%d ",a[i]);
//   printf("\n");
for(i=1;i<k;i++)
{
for(j=2;j<=k;j++)
{
if(a[j]==2*a[i])
sum++;
}
}
printf("%d\n",sum);
memset(a,0,sizeof(a));
sum=0;
k=0;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: