您的位置:首页 > 其它

杭电1078(记忆搜索)

2014-05-29 17:12 218 查看
一道记忆搜索题,记忆搜索题就是搜索的形式+DP的思想!

题目:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0).
He eats up the cheese where he stands and then runs either horizontally or
vertically to another location. The problem is that there is a super Cat named
Top Killer sitting near his hole, so each time he can run at most k locations to
get into the hole before being caught by Top Killer. What is worse -- after
eating up the cheese at one location, FatMouse gets fatter. So in order to gain
enough energy for his next run, he has to run to a location which have more
blocks of cheese than those that were at the current hole.

Given n, k,
and the number of blocks of cheese at each grid location, compute the maximum
amount of cheese FatMouse can eat before being unable to move.

[align=left]Input[/align]
There are several test cases. Each test case consists
of

a line containing two integers between 1 and 100: n and k
n
lines, each with n numbers: the first line contains the number of blocks of
cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number
of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The
input ends with a pair of -1's.

[align=left]Output[/align]
For each test case output in a line the single integer
giving the number of blocks of cheese collected.

[align=left]Sample Input[/align]

3 1

1 2 5

10 11 6
12 12 7
-1 -1

[align=left]Sample Output[/align]

37

思想:
一道记忆搜索题,记忆搜索题就是搜索的形式+DP的思想!

代码:
  超时代码:
  

#include<stdio.h>
#include<string.h>

int map[105][105];
int value[105][105];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int n,k;

int dfs(int sx,int sy)
{
int i,j,x,y,max=0,temp;
if(value[sx][sy]!=-1)       //该点已经计算过,直接返回值
return value[sx][sy];
for(i=0;i<4;i++)            //2个循环控制该点所能走的地方
for(j=1;j<=k;j++)
{
x=sx+dir[i][0]*j;
y=sy+dir[i][1]*j;
if(x<0||x>=n||y<0||y>=n||map[x][y]<=map[sx][sy])    //剪枝
continue;
temp=dfs(x,y);
if(temp>max)        //max保存由该点所能到达之处能吃到的最大奶酪数

max=temp;
}
value[sx][sy]=map[sx][sy]+max;      //得到由该点出发所能吃到的最大奶酪数,保存在value里
return value[sx][sy];
}

int main()
{
int i,j;
while(scanf("%d%d",&n,&k)!=EOF)
{
if(n==-1&&k==-1)
break;
memset(value,-1,sizeof(value));    //初始化数组(不能为0)
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&map[i][j]);
printf("%d\n",dfs(0,0));
}
return 0;
}


网上大神代码
总结:

尽量不要用do....while();
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: