您的位置:首页 > 其它

POJ 1046 Color Me Less

2014-05-28 14:56 507 查看
Color Me Less

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 29983Accepted: 14535
Description
A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target
set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255.
The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation



Input
The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped.
The input is terminated by a line containing three -1 values.
Output
For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.
Sample Input
0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

Sample Output
(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)
用到结构体,一开始被卡到是在输入这块上,给出的映射的5个颜色数组不能够一次输入,按照输入一次就输出一次答案即可。

程序大概:
先输入16个颜色块。然后再是一般的输入工作,while(scanf()!=EOF),输入一条数据就输出一个答案,直到给出的值为文件输入的结束标志为止。

#include <stdio.h>
#include <math.h>
struct color
{
int r;
int g;
int b;
}c[20],ys,print;
int main (void)
{
//freopen("1046.txt","r",stdin);
int n,i,max,d,k,j=0;
for(i=1;i<=16;i++)
{
scanf("%d%d%d",&c[i].r,&c[i].g,&c[i].b);
}
while(scanf("%d%d%d",&ys.r,&ys.g,&ys.b)!=EOF&&(ys.r!=-1||ys.g!=-1||ys.b!=-1))
{
max=sqrt((ys.r-c[1].r)*(ys.r-c[1].r)+(ys.g-c[1].g)*(ys.g-c[1].g)+(ys.b-c[1].b)*(ys.b-c[1].b));
print.r=c[1].r;
print.g=c[1].g;
print.b=c[1].b;
for(k=2;k<=16;k++)
{
d=sqrt((ys.r-c[k].r)*(ys.r-c[k].r)+(ys.g-c[k].g)*(ys.g-c[k].g)+(ys.b-c[k].b)*(ys.b-c[k].b));
if(max>d)
{
max=d;
print.r=c[k].r;
print.g=c[k].g;
print.b=c[k].b;
}
}
printf("(%d,%d,%d) maps to (%d,%d,%d)\n",ys.r,ys.g,ys.b,print.r,print.g,print.b);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: