您的位置:首页 > 其它

POJ 1742 Coins 多重背包用单调队列优化

2014-05-27 22:37 295 查看


多重背包用单调队列优化
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the
exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

       

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The
last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0


Sample Output

8
4
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100000+10;
int c[maxn],w[maxn],use[maxn],f[maxn];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)&&n&&m)
{
int ans=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&w[i]);
}
for(int i=1;i<=n;i++)
{
scanf("%d",&c[i]);
}
memset(f,0,sizeof(f));
f[0]=1;
for(int i=1;i<=n;i++)
{
memset(use,0,sizeof(use));
for(int j=w[
4000
i];j<=m;j++)
{
if(!f[j]&&f[j-w[i]]&&(use[j-w[i]]+1<=c[i]))
{
f[j]=1;
use[j]=use[j-w[i]]+1;
ans++;
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息