您的位置:首页 > 其它

HDU 1016 Prime Ring Problem(简单回溯)

2014-05-27 16:35 316 查看


Problem B


Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 11 Accepted Submission(s) : 8


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1.


Input

n (0 < n < 20).


Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You
are to write a program that completes above process. Print a blank line after each case.


Sample Input

6
8




Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int MAXN=25;
int f[MAXN];
bool done[MAXN];
int csc=0;
int is_prim(int x)
{
	int i;
	int k=sqrt(x);
	for(i=2;i<=k;i++)
		if(x%i==0)break;
	if(i>k)return 1;
	return 0;
}
void select(int n,int cur)
{
	int i;
	if(cur==n+1&&is_prim(f[1]+f
))
	{
		for(i=1;i<=n;i++)
			if(i!=n)printf("%d ",f[i]);
			else printf("%d\n",f[i]);
	}
	if(cur==n+1) return;
	for(i=1;i<=n;i++)
	{
		if(!done[i]&&is_prim(f[cur-1]+i))
		{
			f[cur]=i;
			done[i]=1;
			select(n,cur+1);
			done[i]=0;
		}
	}
}
int main()
{
//	freopen("123.txt","r",stdin);
	int n,i;
	while(~scanf("%d",&n))
	{
		printf("Case %d:\n",++csc);
		memset(done,0,sizeof(done));
		
		f[1]=1;
		done[1]=1;
		select(n,2);
		done[1]=0;

		printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: