您的位置:首页 > 其它

POJ 3616-Milking Time (基础DP)

2014-05-25 16:30 399 查看
Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her nextN (1 ≤
N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each intervali has a starting hour (0 ≤
starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤
N), and a corresponding efficiency (1 ≤efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour
and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must restR (1 ≤
R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in theN hours.

Input

* Line 1: Three space-separated integers: N, M, and R

* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers:starting_houri ,
ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in theN hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31


Sample Output

43


* 将每个时间段的结束时间都加 r , 题目就可转化为求不重叠的时间段的最大权值...

                   (航姐姐说~~凡是妨碍问题变简单的条件都是很讨厌的 )

* dp[i] 表示第i 个时间段 的最大权值...

CODE:

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
int x,y,p;
}milk[1005];

bool cmp(node a,node b)
{
return a.y<b.y;
}
int dp[1005];
int main()
{
//freopen("in.in","r",stdin);
int n,m,r;
int yy;
scanf("%d%d%d",&n,&m,&r);
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&milk[i].x,&yy,&milk[i].p);
milk[i].y=yy+r;
}
sort(milk,milk+m,cmp);
for(int i=0;i<m;i++)
{
dp[i]=milk[i].p;
}
for(int i=0;i<m;i++)
{
for(int j=i+1;j<m;j++)
{
if(milk[j].x>=milk[i].y)
{
dp[j]=max(dp[i]+milk[j].p,dp[j]);
}
}
}
int maxn=dp[0];
for(int i=1;i<m;i++)
{
if(maxn<dp[i]) maxn=dp[i];
}
printf("%d\n",maxn);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP POJ