您的位置:首页 > 其它

【求助】zoj 2476求和水题

2014-05-25 15:23 225 查看
据说是个水题,不过还是总WA。。求大神给瞄一眼。

题目描述如下:

Total Amount

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).

Input

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive.
N=0 denotes the end of input.

Output

For each input test, output the total amount.

Sample Input

2

$1,234,567.89

$9,876,543.21

3

$0.01

$0.10

$1.00

0

Sample Output

$11,111,111.10

$1.11

问题代码如下:

// ZOJ 2476.cpp : 定义控制台应用程序的入口点。
//

#include <iostream>
using namespace std;

int main()
{
int n,totalLeft,totalRight,dotLeft,dotRight;
char ch;
while(cin>>n&&n!=0)
{
totalLeft=0;
totalRight=0;
for(;n>0;n--)
{
cin>>ch;
int sum=0;
while(ch!='.')
{
cin>>dotLeft;
sum+=dotLeft;
cin>>ch;
if(ch==',')sum*=1000;
}
totalLeft+=sum;
cin>>dotRight;
totalRight+=dotRight;

}
totalLeft+=totalRight/100;
cout<<"$";
int baseNum=10000000,numOfZero=7,flag=0;

while(numOfZero)
{
if(flag==0&&totalLeft/baseNum)
{
cout<<totalLeft/baseNum;
flag=1;
}
else if(flag){
if((numOfZero+1)%3==0)cout<<',';
cout<<totalLeft/baseNum;
}
totalLeft%=baseNum;
baseNum/=10;
numOfZero--;
}
cout<<totalLeft<<'.';
totalRight%=100;
if(totalRight==0)cout<<"00"<<endl;
else cout<<totalRight<<endl;

}

//int sum=0;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: